Rails 環境格闘記 !未完成!

Ignoring executable-hooks-1.4.2 because its extensions are not built. Try: gem pristine executable-hooks --version 1.4.2

このエラーが出る。 nokogirを指定の通り入れてもだめ。 この場合pathが通っていないことが多い よってgem の環境を確認.

 $ gem environment
RubyGems Environment:
  - RUBYGEMS VERSION: 2.7.6
  - RUBY VERSION: 2.5.1 (2018-03-29 patchlevel 57) [x86_64-linux]
  - INSTALLATION DIRECTORY: /usr/local/rvm/gems/ruby-2.4.1
  - USER INSTALLATION DIRECTORY: /home/ec2-user/.gem/ruby/2.5.0
  - RUBY EXECUTABLE: /home/ec2-user/.rbenv/versions/2.5.1/bin/ruby
  - EXECUTABLE DIRECTORY: /usr/local/rvm/gems/ruby-2.4.1/bin
  - SPEC CACHE DIRECTORY: /home/ec2-user/.gem/specs
  - SYSTEM CONFIGURATION DIRECTORY: /home/ec2-user/.rbenv/versions/2.5.1/etc
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-linux
  - GEM PATHS:
     - /usr/local/rvm/gems/ruby-2.4.1
     - /usr/local/rvm/gems/ruby-2.4.1@global
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :backtrace => false
     - :bulk_threshold => 1000

rbenvで入れたのに実行環境がRVMになっている?? 再度rvmで入れることが可能なのか? このサイトを見ると不可能にちかい。というかエラーになること間違いない。

RVMからrbenvに移行した手順まとめ · GitHub rvmインストールしていないのだから、pathをrbenvに向けてあげればいいだけ。 以下明日に続く